Back to the main page.

Bug 1226 - nanstd: segmentation fault on single precision

Reported 2011-12-09 13:39:00 +0100
Modified 2012-01-03 11:29:59 +0100
Product: FieldTrip
Component: core
Version: unspecified
Hardware: PC
Operating System: Linux
Importance: P3 normal
Assigned to: Jan-Mathijs Schoffelen
Depends on:
See also:

Roemer van der Meij - 2011-12-09 13:39:28 +0100

Maybe it's our specific Linux machine, but maybe not, as nanmean works perfectly. nanstd(double(rand(1000); -> works fine nanstd(single(rand(1000); -> segmentation fault In contrast (you implemented both no JM?): nanmean(double(rand(1000); -> works fine nanmean(single(rand(1000); -> works fine If my specific matlab error report helps, I'll gladly post it! (I never worked with these kind of errors, so no idea)

Jan-Mathijs Schoffelen - 2011-12-09 17:00:40 +0100

error reproduced

Jan-Mathijs Schoffelen - 2011-12-09 17:01:12 +0100

No reason why it shouldn't work. I found a small error in the source-code and will recompile for linux64

Jan-Mathijs Schoffelen - 2011-12-09 17:03:03 +0100

fixed for linux64 on revision 4975 TODO: recompile for the other platforms

Roemer van der Meij - 2011-12-09 17:13:30 +0100

Wow, that's quick :). Hmmm, I just tried it after doing a svn update to 4978, but still had asegementation fault doing nanstd(single(rand(1000))).

Jan-Mathijs Schoffelen - 2011-12-09 18:22:18 +0100

do you also get the error when calling nanstd from fieldtrip/src? which nanstd are you using (full path)?

Roemer van der Meij - 2011-12-09 23:37:33 +0100

It works perfectly now, maybe I missed something when updating my own paths, sorry. Thanks for the quick fix! (using trunk/private/nanstd.mexa64)