Back to the main page.

Bug 1267 - error while running "ft_timelockstatistics"

Reported 2012-01-18 13:22:00 +0100
Modified 2012-03-21 15:44:45 +0100
Product: FieldTrip
Component: core
Version: unspecified
Hardware: PC
Operating System: Windows
Importance: P3 major
Assigned to: Jan-Mathijs Schoffelen
Depends on:
See also:

Yoni Levy - 2012-01-18 13:22:15 +0100

there is reference to 'D:\fieldtrip-20111221\statfun\private\nanstd.mexw64' which is not found there. is it just a question of version (I have a fieldtrip version of one month ago) thanks, Yoni "> In statfun\private\warning_once at 81 In statfun_indepsamplesT at 68 In statistics_analytic at 81 In fieldtrip-20111221\private\statistics_wrapper at 296 In ft_timelockstatistics at 110 Invalid MEX-file 'D:\fieldtrip-20111221\statfun\private\nanstd.mexw64': Le module spécifié est introuvable."

Jan-Mathijs Schoffelen - 2012-01-18 14:07:51 +0100

Yes, please update to a new version and check in the folder statfun/private whether nanstd.mexw64 is present.

Jan-Mathijs Schoffelen - 2012-01-18 14:08:59 +0100

could you report back whether it is fixed?

Yoni Levy - 2012-01-18 15:56:14 +0100

(In reply to comment #2) I have been trying for the last couple of hours to redownload a newer version of fieldtrip, but there seems to be a problem with the server, and all downloads get stuck at some point. The latest version I managed to download was of the 11th of December, but it didnt contain the file nanstd.mexw64 (instead, it contains 'nanstd.mexw32'). Is there any other way to proceed? Thanks

Yoni Levy - 2012-01-18 16:09:34 +0100

(In reply to comment #3) i meant in my prior email the january 11th version; i now also managed to get the january 13th version; it also lacks the abovementioned file --- is it certainly that in the version of yesterday the file is present?? thanks

Jan-Mathijs Schoffelen - 2012-01-18 16:15:50 +0100

yes, see: you can also obtain a copy of the most up-to-date version at:

Yoni Levy - 2012-01-18 16:22:12 +0100

(In reply to comment #5) ok, i just managed downloading the latest version, and actually the problem also persists here: the nanstd.mexw64 doesnt exist here either (in 'statfun\private\' directory). Any suggestions how to proceed and run successfully ft_timelockstatistics? thanks

Jan-Mathijs Schoffelen - 2012-01-18 16:43:11 +0100

but is there a nanstd.m function?

Jan-Mathijs Schoffelen - 2012-01-18 16:47:24 +0100

it should be present in fieldtrip/src/ you can copy it over to statfun/private.

Yoni Levy - 2012-01-18 16:56:27 +0100

(In reply to comment #8) no, it's not in SRC either, only the 'nanstd.mexw32' file, but when i run the script i receive the error message that it cannot find 'nanstd.mexw64'

Jan-Mathijs Schoffelen - 2012-01-18 16:59:56 +0100

does the nanstd.m function exist?

Jan-Mathijs Schoffelen - 2012-01-18 17:01:53 +0100

If the compiled mex filed (which is the nanstd.mexw64) does not exist, fieldtrip should revert to using nanstd.m. So I don't understand why you get the error to begin with.

Yoni Levy - 2012-01-18 17:15:52 +0100

(In reply to comment #11) in the latest fieldtrip version, there are two nanstd files, one 'matlab code', another 'matlab mex'. I have no idea why the error is there; this is the full error message that i get when i run timelockstatistics: >> eval(['t_subj' num2str(tt) ' =ft_timelockstatistics(cfg,ww,ll);']); averaging over 274 channels selected 2222 time bins selected 1 frequency bins using "statistics_analytic" for the statistical testing using 'statfun_indepsamplesT' to compute the single-sample statistic and probability Warning: Not all replications are used for the computation of the statistic. > In statfun\private\warning_once at 75 In statfun_indepsamplesT at 68 In statistics_analytic at 81 In fieldtrip-20120117\private\statistics_wrapper at 296 In ft_timelockstatistics at 110 Invalid MEX-file 'D:\fieldtrip-20120117\statfun\private\nanstd.mexw64': Le module spécifié est introuvable. Error in statfun_indepsamplesT (line 79) var1 = nanstd(dat(:,sel1), 0, 2).^2; Error in statistics_analytic (line 81) [stat, cfg] = statfun(cfg, dat, design); Error in statistics_wrapper (line 296) [stat, cfg] = statmethod(cfg, dat, design); Error in ft_timelockstatistics (line 110) [stat, cfg] = statistics_wrapper(cfg, varargin{:}); >>

Jan-Mathijs Schoffelen - 2012-01-18 17:41:29 +0100

please remove all nanstd files apart from the nanstd.m and try again. To be safe, first quit matlab and start a new session.

Yoni Levy - 2012-01-18 18:00:13 +0100

(In reply to comment #13) ok wonderful; bug is resolved on my pc :-)