Back to the main page.

Bug 1568 - EGI layout fails for ft_databrowser with components

Reported 2012-06-28 11:49:00 +0200
Modified 2019-08-10 11:56:47 +0200
Product: FieldTrip
Component: plotting
Version: unspecified
Hardware: PC
Operating System: Mac OS
Importance: P3 normal
Assigned to:
Depends on:
See also:

Robert Oostenveld - 2012-06-28 11:49:18 +0200

Johanna wrote by email: Just a minor thing, but a girl here with 256 EGI cap is successfully using ICA and the ft_topoplot for the components, with 'GSN-HydroCel-256.sfp' as cfg.layout. But when she uses ft_databrowser to see the components, the topographies themselves go off the side of the left square of the figure, so you can only see the right half of the sensor layout. the time courses appear fine. Any idea for this visualization issue? ----- TODO to reproduce the bug: create a raw data structure with the channels from GSN-HydroCel-256.sfp, run componentanalysis with method=pca, visualize in ft_databrowser. TODO for solving it: ft_databrowser should not make assumptions on the spatial dimensions contained in the layout. They can be -0.5 to 0.5, or pixels, or arbitrary scaled and offset. Probably ft_databrowser should be translating and scaling the layouts such that they match the expected values for the position (e.g. always between 0 and 1)

Johanna - 2012-07-02 11:29:53 +0200

*** Bug 1569 has been marked as a duplicate of this bug. ***

Roemer van der Meij - 2012-08-02 15:05:09 +0200

This also occurs with the ctf151 layout with data taken from the tutorial. Assigning to me. Johanna, do you maybe know of an example where it works in the current version? Or is it always broken?

Johanna - 2012-08-02 15:13:19 +0200

As of a few months ago, it worked fine for me to plot ICA components in ft_databrowser with my EEG BrainProducts data using elec1010.lay.

Roemer van der Meij - 2012-08-02 15:16:20 +0200

You're fast :). Is a tiny snapshot of that data available somewhere? Or could you attach a tiny bit? Then I can back-check whether my to-be-build-fix didn't break it when it worked

Johanna - 2012-08-02 15:40:09 +0200

well, now it doesn't work for me anymore, with elec1010.lay (I only see right half of sensor topo), on data where it certainly did work several months ago.

Roemer van der Meij - 2012-08-02 15:42:11 +0200

I changed some of the location stuff. Could you update and check to verify it is fixed?

Johanna - 2012-08-02 15:49:39 +0200

Yes, it does now plot the full topos correctly. Only thing now is that it is slow to update: first only the time series appear, taking up the full width of the plot, then seconds later the topos appear, displacing the time-series enough to fit. If someone doesn't know to be patient, they could think at first that no topos will appear. I don't recall this happening before, and the mentat I'm on is not busy/full.

Roemer van der Meij - 2012-08-02 15:51:08 +0200

It's the same over here, I will file it as a new bug and see whether I can optimize it (I'll cc you)

Robert Oostenveld - 2019-08-10 11:56:47 +0200

This closes a whole series of bugs that have been resolved (either FIXED/WONTFIX/INVALID) for quite some time. If you disagree, please file a new issue describing the issue on