Back to the main page.

Bug 1766 - check the test_headmodel_xxx scripts

Reported 2012-10-04 09:49:00 +0200
Modified 2012-10-04 23:13:13 +0200
Product: FieldTrip
Component: forward
Version: unspecified
Hardware: PC
Operating System: Mac OS
Importance: P3 normal
Assigned to: Robert Oostenveld
Depends on:
See also:

Jan-Mathijs Schoffelen - 2012-10-04 09:49:34 +0200

when fixing the function in order for it not showing up as 'failed' on the dashboard, I looked at the output figures, which look really strange. Verify whether this is expected.

Robert Oostenveld - 2012-10-04 20:18:22 +0200

although the asa one passes the test, some others from this series don't test_headmodel_singlesphere_new_old.m test_headmodel_bemcp_new_old.m test_headmodel_dipoli_new_old.m test_headmodel_fns.m test_headmodel_openmeeg.m test_headmodel_openmeeg_new_old.m test_headmodel_simbio.m

Robert Oostenveld - 2012-10-04 20:28:55 +0200

(In reply to comment #0) I checked, it was due to randn as electrodes, without scaling them to a unit sphere, After scaling them to a sphere it is fine (and they get projected properly. Also with the true electrode positions it is fine. roboos@mentat001> svn commit Sending test/test_headmodel_asa.m Transmitting file data . Committed revision 6679. See I will continue with the others :-(

Jan-Mathijs Schoffelen - 2012-10-04 20:41:55 +0200

ja, dus?

Jan-Mathijs Schoffelen - 2012-10-04 20:43:07 +0200

I referred to the figures that look like nonsense to me. Some of the other scripts fail, particularly because of some hard coded filenames to files sitting on crimics home-directory.

Jan-Mathijs Schoffelen - 2012-10-04 20:43:36 +0200

oops. Didn't see that you already fixed the strange figures. Sorry.

Robert Oostenveld - 2012-10-04 20:53:41 +0200

(In reply to comment #5) het leek wel op een bloemetje ;-) maar dan wel eentje uit de kleuterklas

Robert Oostenveld - 2012-10-04 20:54:00 +0200

(In reply to comment #1) roboos@mentat001> svn commit Sending test/test_headmodel_singlesphere_new_old.m Transmitting file data . Committed revision 6680. This one was simply not finished. The tests themselves worked fine when comparing the leadfields, not the vol structs that have trivial differences, such as vol.cfg and round-off errors.

Robert Oostenveld - 2012-10-04 21:47:01 +0200

roboos@mentat001> svn commit forward/test/test_headmodel_concentricspheres_new_old.m forward/test/test_headmodel_singlesphere_new_old.m forward/ft_headmodel_concentricspheres.m forward/private/eeg_leadfield1.m ft_prepare_concentricspheres.m Sending forward/ft_headmodel_concentricspheres.m Sending forward/private/eeg_leadfield1.m Sending forward/test/test_headmodel_concentricspheres_new_old.m Sending forward/test/test_headmodel_singlesphere_new_old.m Sending ft_prepare_concentricspheres.m Transmitting file data ..... Committed revision 6684. this one did not test correctly due to a try-catch Furthermore, there was a mess-up of vol.c and vol.cond, and there was a mess-up of teh default conductivity values. The test now runs correctly.

Robert Oostenveld - 2012-10-04 22:09:30 +0200

roboos@mentat001> svn commit `cat out` Sending forward/test/test_headmodel_bemcp_new_old.m Sending ft_prepare_bemmodel.m Transmitting file data .. Committed revision 6688. this one was not too hard.

Robert Oostenveld - 2012-10-04 22:26:45 +0200

roboos@mentat001> svn commit `cat out` Sending external/dipoli/dipoli.m Adding external/dipoli/private Adding external/dipoli/private/bounding_mesh.m Adding external/dipoli/private/find_innermost_boundary.m Adding external/dipoli/private/find_outermost_boundary.m Adding external/dipoli/private/solid_angle.m Adding (bin) external/dipoli/private/solid_angle.mexa64 Adding (bin) external/dipoli/private/solid_angle.mexglx Adding (bin) external/dipoli/private/solid_angle.mexmac Adding (bin) external/dipoli/private/solid_angle.mexmaci Adding (bin) external/dipoli/private/solid_angle.mexmaci64 Adding (bin) external/dipoli/private/solid_angle.mexw32 Adding (bin) external/dipoli/private/solid_angle.mexw64 Sending forward/test/test_headmodel_dipoli_new_old.m Transmitting file data ..... Committed revision 6689. I removed the try-catch and am now comparing on the leadfield values there were no real problems in getting this one to run

Robert Oostenveld - 2012-10-04 22:45:36 +0200

roboos@mentat001> svn commit forward/test/ Sending forward/test/test_headmodel_singleshell_new_old.m Transmitting file data . Committed revision 6690. this one runs after some revisions and making it a proper test

Robert Oostenveld - 2012-10-04 22:51:57 +0200

roboos@mentat001> svn commit Sending test/test_headmodel_localspheres_new_old.m Transmitting file data . Committed revision 6691. worked fine (after revisions)

Robert Oostenveld - 2012-10-04 23:13:13 +0200

roboos@mentat001> svn commit Sending forward/test/test_headmodel_openmeeg_new_old.m Transmitting file data . Committed revision 6693. some restructuring and small changes. I also installed the dependencies in /opt/openmeeg for the whole centre to use.