Back to the main page.

Bug 2113 - test report e-mail does not work properly anymore

Reported 2013-04-16 09:32:00 +0200
Modified 2014-01-29 13:28:30 +0100
Product: FieldTrip
Component: test
Version: unspecified
Hardware: PC
Operating System: Windows
Importance: P3 normal
Assigned to: Eelke Spaak
Depends on:
See also:

Eelke Spaak - 2013-04-16 09:32:15 +0200

As of April 12, it seems. Also note the weird dashes (no pun intended) on the dashboard page: some of them are no longer minus signs (-) but en-dashes (—). Related?

Jörn M. Horschig - 2013-04-16 10:21:46 +0200

at least we now know what it says when all tests are passing :o)

Robert Oostenveld - 2013-04-16 12:54:34 +0200

the dashes are due to a double short-dash -- being rendered as a single long-dash. It has been like this forever, so is not related. I suspect it being due to my central storage quotum being full (last week), causing write problems. I cleaned up, there is again space but apparently the test suite still does not run properly.

Robert Oostenveld - 2013-04-16 12:59:24 +0200

I am trying to do it manually: one problem seems to be roboos@mentat001> /home/mrphys/roboos/fieldtrip/dashboard/ Finding old checkouts to remove... Removing ... Getting latest revision... svn: Working copy '.' locked svn: run 'svn cleanup' to remove locks (type 'svn help cleanup' for details) I ran svn cleanup, see whether that helps...

Robert Oostenveld - 2013-04-16 23:00:58 +0200

it did not help. more digging around showed a stale pickle... there is a python script that writes results to a "pickle" file (one per revision). One of those was corrupt, causing the parsing of the whole collection of files to fail. Hopefully the mails will now get started again.

Robert Oostenveld - 2013-04-17 09:35:42 +0200

I manually started the script that sends the mail and it worked.

Eelke Spaak - 2014-01-29 13:28:30 +0100

changing lots of bugs from resolved to closed.