Back to the main page.

Bug 2337 - ft_topoplotER calls ft_freqbaseline on frequency data without time axis

Reported 2013-10-25 14:05:00 +0200
Modified 2013-10-28 11:58:39 +0100
Product: FieldTrip
Component: plotting
Version: unspecified
Hardware: PC
Operating System: Linux
Importance: P3 normal
Assigned to: Robert Oostenveld
Depends on:
See also:

Federico - 2013-10-25 14:05:39 +0200

Hello, I am plotting through topoplotER(cfg,freq) , where I am using power spectrum ( witouth time dimension), which has been produced bz FT_freqanalysis. The fact is that when I execute my script, it appears an error, calling to freq.time: Error in ft_freqbaseline (line 103) freqOut.time = freq.time; And in my freq output it does not appear any time. Actually in the description of topoplotER, is clear that with powerSpectrum is not necessary time. I think it could be a bug, and I can not fix it. Thanks!

Robert Oostenveld - 2013-10-25 14:57:34 +0200

Hi Frederico, ft_freqbaseline should not have been called, as that pertains to normalizing time-frequency data (using a baseline window somewhere along the time-axis, usually pre-stim). Could you attach a mat file with your freq structure and your cfg to this bug (or send it in another way, e.f. through dropbox, if it is too large)? That will help to reproduce the issue. thanks Robert

Federico - 2013-10-25 15:15:50 +0200

Created attachment 539 freq Hey Robert, Is not possible to me right now upload the .mat. I have done two screenshots, maybe this is enough, if is not, I will do it later (it is 500MB/each). I really don't see the fail, I am becoming crazy! haha Regards

Federico - 2013-10-25 15:16:06 +0200

Created attachment 540 Freq

Robert Oostenveld - 2013-10-25 15:24:43 +0200

the screenshot does not give enough information as to why ft_multiplotER ends up calling ft_freqbaseline. large uploads to bugzilla indeed don't work. Please see

Federico - 2013-10-25 15:38:07 +0200

Yeah.. I know, is not enough information. Okay, I've tried to upload there by coping the file, but it seems that it has not been copied. Can I copy it directly by typing and upload it? I've tried but I don't see any buttom to upload, I tried to copy it directly by moving the .mat file, but it is like if it download in my computer. What should I do? I am so sorry for the inconveniences, I am only using Fieldtrip for one week. Thank you Best, Federico

Robert Oostenveld - 2013-10-25 15:45:24 +0200

(In reply to comment #5) if you are not so familiar with ftp (and who is nowadays), I suggest one of

Federico - 2013-10-25 16:16:39 +0200

Thanks Robert, I uploaded the .mat in:

Federico - 2013-10-28 09:58:40 +0100

Hey Robert, did you see if it was my fail or some of the code? I still don't see the problem! Thanks!

Robert Oostenveld - 2013-10-28 10:37:48 +0100

(In reply to comment #8) The exchange of freq.mat somehow failed: >> cd ~/Downloads/ >> load freq.mat unexpected end-of-file while reading compressed data unexpected end-of-file while reading compressed data unexpected end-of-file while reading compressed data Error using load Can't read file /Volumes/Data/roboos/Downloads/freq.mat. So freq.mat is appears to be corrupt. The download for cfg.mat is still busy (at only 100kB/s, will take another hour). But I don't understand why cfg.mat is so large (>400MB). It should only contain the cfg structure, right? Can you save the files once more and reupload? Which matlab version on which operating system are you using?

Federico - 2013-10-28 11:39:35 +0100

I did already fix it! Thank you!

Robert Oostenveld - 2013-10-28 11:58:39 +0100

(In reply to comment #10) you mean that you resolved the problem? What was causing the issue then?