Back to the main page.

Bug 2581 - thinkgear2ft.exe cannot connect to the neurosky mindwave event through neurosky thinkgear

Reported 2014-05-15 11:13:00 +0200
Modified 2015-02-11 10:43:16 +0100
Product: FieldTrip
Component: realtime
Version: unspecified
Hardware: PC
Operating System: Windows
Importance: P5 normal
Assigned to: Robert Oostenveld
Depends on:
See also:

Petar J - 2014-05-15 11:13:27 +0200

I tried to connect to the neurosky mindwave device alone and with neurosky thinkgear running. There was no success, even though COM11 serial port was used and registered in neurosky thinkgear application. The error was "Unable to connect to the COM11 serial port", I tried other ports as well, but with no success. I also tested connection through port COM11 with BCI2000 and it works perfectly, so the connection itself is not a problem. I have to state that COM9 serial port manages to go through and connect (regardless of the device connectivity status), but there is no data sent to the buffer, only the header, with no subsequent data sent, probably because the device is on COM11. I am using a simple configuration file [select] 1=Ns1 2=Ns2 3=Ns3 4=Ns4 5=Ns5 6=Ns6 7=Ns7

Robert Oostenveld - 2014-05-15 11:38:41 +0200

Hi Petar, We don't have a neurosky mind wave device, which makes it difficult for us to help you in debugging it. Also, the person who wrote the code has left since. The error that you give is one that I cannot find in the source code files in fieldtrip/realtime/src/acquisition/neurosky, which suggests that it is a system error rather than an error in the code. Might it be that some other piece of software is blocking the thinkgear2ft.exe to access the port? I'll include a colleague at another centre here on the discussion: @Jason, do you happen to have a neurosky headset?

Petar J - 2014-05-19 18:25:10 +0200

Hi Robert and Jason, I got this neurosky mindwave device, useful for portable BCI presentation, but I can't seam to get it to work. I don't believe any other piece of software is blocking the thinkgear2ft.exe to access the port, since I can connect to COM9 without problem, but there is nothing there. BCI2000 can reach the device through COM11, on the same machine, so the connection works. I disabled firewall completely. //Petar

Robert Oostenveld - 2014-05-20 18:40:27 +0200

(In reply to Petar J from comment #2) why don't you use com11 for thinkgear2ft.exe?

Petar J - 2014-05-22 11:59:54 +0200

Because I get an error "Unable to connect to the COM11 serial port", if i use COM11.

Robert Oostenveld - 2014-05-22 13:46:17 +0200

(In reply to Petar J from comment #4) and if you connect to com9 you also don't get data. If bci2000 needs to connect to com11, neurosky2ft.exe would also need to connect to it. I don't see how the neurosky device would reconfigure itself. did you debug the serial communication using programs such as the ones found on google?

Petar J - 2014-05-27 17:07:09 +0200

No I haven't, so I am not sure of what is going on between the two. I just reported the problem, hopefully you can recreate it ad fix it (providing the is a problem and not just my clumsiness)

Jason Farquhar - 2014-07-01 11:39:02 +0200

(In reply to Petar J from comment #6) Dear Petar, Robert, I've just tried the thinkgear2ft on a windows 7 machine we have here. Connecting to the device was fine (once I had installed the mindwave tools). I couldn't actually get any data out of it (due to lots of invalid-packet errors), however Petar's reported problem of not being able to access the device was not a problem. Note however, I was running as administrator... Jason