Back to the main page.

Bug 2643 - ft_sourceinterpolate crashes (Undefined function or variable 'abort')

Reported 2014-07-09 12:31:00 +0200
Modified 2019-08-10 12:29:03 +0200
Product: FieldTrip
Component: core
Version: unspecified
Hardware: PC
Operating System: Mac OS
Importance: P5 normal
Assigned to:
Depends on:
See also:

Izabela Mikula - 2014-07-09 12:31:17 +0200

ft_sourceinterpolate crashes in line 105: Undefined function or variable 'abort'. Previous version of fieldtrip (20131231) works fine with the script/parameters used. Probably similar to BUG ID 2580.

Robert Oostenveld - 2014-07-09 12:35:01 +0200

In case of bug 2580 it was an error on the users side, i.e. the fieldtrip version that both Ayelet and Yuliya were using on their local computers was corrupt. That is not something we can fix. From which location are you using fieldtrip? From your own computer, or from /home/common?

Robert Oostenveld - 2014-07-09 12:37:44 +0200

(In reply to Robert Oostenveld from comment #1) if it is from home common, it might be related to bug 2643. That also does not appear to be fieldtrip error, but a problem with the compute cluster storage.

Eelke Spaak - 2014-07-09 14:50:04 +0200

My office mate Xu Gong was also experiencing this problem, with basically all FT functions. I fixed it by doing: restoredefaultpath addpath /home/common/matlab/fieldtrip/ ft_defaults and then everything worked again. However, I don't really understand the cause, and/or why doing this fixed it.

Robert Oostenveld - 2014-07-09 15:20:40 +0200

it suggests a temporary corruption in the file system. @Izabela and Xu should report it at the TG (letting the TG know that there was a problem, and that the problem is not there any more).

Robert Oostenveld - 2019-08-10 12:29:03 +0200

This closes a whole series of bugs that have been resolved (either FIXED/WONTFIX/INVALID) for quite some time. If you disagree, please file a new issue describing the issue on