Back to the main page.

Bug 2656 - Matlab crashes when calling ft_databrowser in TMS-EEG tutorial

Reported 2014-07-17 09:42:00 +0200
Modified 2019-08-10 12:33:21 +0200
Product: FieldTrip
Component: preproc
Version: unspecified
Hardware: PC
Operating System: Windows
Importance: P5 normal
Assigned to: Jim Herring
Depends on:
Blocks: 2314
See also:

Bjørn - 2014-07-17 09:42:13 +0200

First off, I would like to express my thanks to the people who created, and maintain, this toolbox. As a new phd student within the field, it is a godsend and it seems great! However, I think I encountered a bug. I am no computer wiz, so I may well be overlooking something obvious, but here is what happens on my computer: I followed the TMS-EEG tutorial on your site, and after getting approximateyl half way, I am asked to look for non-TMS related artifacts to exclude. To do this, I need to plot the non-timelocked ICA components, and the following code is suggested: cfg = []; cfg.layout = 'easycapM10'; cfg.viewmode = 'component'; % Mode specifically suited to browse through ICA data ft_databrowser(cfg, comp_tms); comp_tms above is a file saved from earlier, containing the ICA analysis data in a .mat file. Running this code led to "an internal problem" and matlab "needs to close". This happened first after going through the entire tutorial, but when I run the above code (alone), only having 'comp_tms' loaded in my workspace, I still get the same error message. Hopefully this is just some minor thing, and likely it is me doing something wrong, but it would be great if it was fixable, as the tutorial so far was great! Thank you for reading the report. Best regards, Bjørn PS. I run a 64 bit windows, and matlab 2013b

Jörn M. Horschig - 2014-07-17 12:44:52 +0200

HI Björn, I assume you are using windows 7, aren't you? There is some unfortunate issue... see here: (click on "next message" so read the whole conversation. The Mathworks team helped and apparently it's a combination of OS, graphics card and Matlab specific settings. Martine (see link) solved it by adding set(gcf,'renderer','painters'); before line 242 in the function ft_plot_topo Best, Jörn

Jan-Mathijs Schoffelen - 2014-09-10 13:46:42 +0200

Suggestion to turn this into a FAQ.

Roemer van der Meij - 2016-05-09 23:54:08 +0200

Changed status to reflect bug, and resolved

Robert Oostenveld - 2019-08-10 12:33:21 +0200

This closes a whole series of bugs that have been resolved (either FIXED/WONTFIX/INVALID) for quite some time. If you disagree, please file a new issue on