Back to the main page.

Bug 2693 - update the wiki to the latest version

Reported 2014-09-20 20:28:00 +0200
Modified 2015-02-11 10:40:45 +0100
Product: FieldTrip
Component: documentation
Version: unspecified
Hardware: PC
Operating System: Mac OS
Importance: P5 normal
Assigned to: Robert Oostenveld
Depends on:
See also:

Robert Oostenveld - 2014-09-20 20:28:41 +0200

Robert Oostenveld - 2014-09-20 20:29:42 +0200

I installed the latest version, which is dokuwiki-2014-05-05a. To not disturb the current wiki, I installed it under ""

Robert Oostenveld - 2014-09-20 20:42:24 +0200

I compared the list of plugins from the old one, and automatically installed the wallowing on the new one (i.e. the latest version) - captcha - google analytics - include - logstats - note - orphanswanted - pagelist - rater - searchindex - sortablejs - tag - twitter - vshare Still to manually are - goto - edittweet (from eelke) - inlinebib (from eelke) - svgpureInsert (incorrect file name) Not needed (I think) are - cloud - disqus - dw2pdf - googlemaps - offline (there are more recent versions of this) - popularity (probably now built in) - safenrecode (probably built in) - siteexport - statdisplay - userpoll

Robert Oostenveld - 2014-09-20 20:57:02 +0200

cd /var/www/ sudo mv svg_pureinsert svgpureinsert this fixes the problem with the "_" in the name

Robert Oostenveld - 2014-09-20 21:01:28 +0200

installed dw2pdf

Robert Oostenveld - 2014-09-20 21:12:56 +0200

I copied the FIeldTripV2 template layout to lib/tlp, but it does not work.

Robert Oostenveld - 2014-09-20 22:27:15 +0200

I still cannot get the FieldTripV2 template to work. Pretty links work (htaccess), it does not matter whether it is at /new/ or at /, in either case the stylesheet will not load.

Robert Oostenveld - 2014-09-20 22:38:08 +0200

I installed the arctic template, works fine. I also installed the A_Centered_Perspective template, works fine. It is the one that seems to be closest to the FIeldTripV2 design and is also by a developer that goes with the name Anymorphic.

Eelke Spaak - 2014-09-24 08:05:50 +0200

Robert, could you recursively change group ownership of the entire /new/ tree to fieldtrip (I think I'm a member also on the webserver), and set rwx permissions for the group? Then I can try to get it all working.

Robert Oostenveld - 2014-09-24 08:40:46 +0200

(In reply to Eelke Spaak from comment #8) I changed them to roboos@dccn-l024:/var/www/ 1017 $ ls -al total 108 drwxr-xr-x 6 apache apache 4096 Sep 20 23:03 . drwxr-xr-x. 28 root root 4096 Sep 20 21:51 .. -rw-rw-rw- 1 roboos fieldtrip 3529 Sep 20 21:31 .htaccess -rw-rw-rw- 1 roboos fieldtrip 1509 Jun 25 18:59 .htaccess.dist -rw-rw-rw- 1 roboos fieldtrip 18092 Jun 25 18:59 COPYING -rw-rw-rw- 1 roboos fieldtrip 306 Jun 25 18:59 README -rw-rw-rw- 1 roboos fieldtrip 30 Jun 25 18:59 VERSION drwxrwxrwx 2 roboos fieldtrip 4096 Jun 25 18:59 bin drwxrwxrwx 2 roboos fieldtrip 4096 Sep 22 12:23 conf lrwxrwxrwx 1 roboos fieldtrip 39 Sep 20 23:03 data -> /var/www/fieldtrip.fcdonders.nl_01/data -rw-rw-rw- 1 roboos fieldtrip 2321 Jun 25 18:59 doku.php -rw-rw-rw- 1 roboos fieldtrip 19091 Jun 25 18:59 feed.php drwxrwxrwx 6 roboos fieldtrip 4096 Jun 25 18:59 inc -rw-rw-rw- 1 roboos fieldtrip 182 Jun 25 18:59 index.php -rw-rw-rw- 1 roboos fieldtrip 20166 Jun 25 18:59 install.php drwxrwxrwx 8 roboos fieldtrip 4096 Jun 25 18:59 lib this should allow you to change them on the command line as eelspa@webserver, and also use the web UI to change them (i.e. apache@webserver). It should not stay like this too long...

Robert Oostenveld - 2014-09-24 08:42:54 +0200

(In reply to Robert Oostenveld from comment #9) I created an admin account for you. Once up and running, we should migrate the existing user accounts to the new version.

Eelke Spaak - 2014-09-24 08:50:26 +0200

(In reply to Robert Oostenveld from comment #9) Thanks. Only conf/local.php and conf/local.php.bak are not yet writeable by me (which I do need).

Robert Oostenveld - 2014-09-24 08:56:53 +0200

(In reply to Eelke Spaak from comment #11) those seem to have be overwritten by apache when I made your account. I changed them into -rw-rw-rw- 1 apache apache 838 Sep 24 08:45 local.php -rw-rw-rw- 1 apache apache 819 Sep 24 08:43 local.php.bak

Eelke Spaak - 2014-09-24 09:58:59 +0200

Our template seems to be working again. I've also re-installed the edittweet and inlinebib plugins.

Eelke Spaak - 2014-09-24 10:10:25 +0200

(In reply to Eelke Spaak from comment #13) Note though that still the mediabrowser etc. is not working, but I'm on it.

Eelke Spaak - 2014-09-24 10:44:04 +0200

I think now all is working, and the new one is ready to migrate. I've also just copied all the users from the old one to the new one, that works as well it seems.

Robert Oostenveld - 2014-09-24 10:55:15 +0200

please all take notice, Eelke upgraded the wiki to the latest version of the dokuwiki CMS software. I will swap the old and new version during or immediately following the FT meeting this afternoon. That means that during that time, you should not be editing a page!

Robert Oostenveld - 2014-09-24 11:19:32 +0200

(In reply to Eelke Spaak from comment #15) I changed the ownership and permissions back to the safe restricted ones (roboos:fieldtrip), except for config and users. I symlinked fieldtest to 03, to give it a try with the full URL instead of subdir. I noticed that the index is not up to date, and that does not work due to a javascript problem. I tried both Safari and Firefox.

Robert Oostenveld - 2014-09-24 11:22:10 +0200

download.php is not yet present. Perhaps there are other php scripts missing from the top-level directory.

Eelke Spaak - 2014-09-24 13:27:56 +0200

(In reply to Robert Oostenveld from comment #18) This now works: I am currently rebuilding the index (takes a long time), this possibly needs to be done again when we go live? Also I tried copying these files over, but could not because of permissions: downloads.php gettweets.php tweetcache.txt robots.txt favicon.ico I think that's it. And then there is the folder /tweetmail/, which is also used, namely by a cronjob. The script checks for new posts to the mailing list and, if present, tweets about them. This script does not, I think, necessarily need to be in the webroot. However, it also can't hurt to keep it there (and that might be convenient given that the webserver is guaranteed to have a working PHP installation).

Eelke Spaak - 2014-09-24 13:37:45 +0200

(In reply to Eelke Spaak from comment #19) The indexing through the browser seems to have crashed, not sure why (not a javascript error). Possibly this is due to there being a LOT of files? I tried it using the shell: cd /var/www/ ./indexer.php -c but that one requires permissions I don't have (so you could try it with sudo). I hope/assume the shell version of the script will be faster than through the browser.

Robert Oostenveld - 2014-09-24 14:29:21 +0200

*** Bug 2694 has been marked as a duplicate of this bug. ***

Robert Oostenveld - 2014-09-24 16:21:55 +0200

copied the icon cp fieldtrip.fcdonders.nl_01/favicon.ico

Robert Oostenveld - 2014-09-24 16:22:49 +0200

(In reply to Robert Oostenveld from comment #22) copied download.php

Robert Oostenveld - 2014-09-24 16:26:20 +0200

(In reply to Robert Oostenveld from comment #23) 1065 $ cp fieldtrip.fcdonders.nl_01/biositemap.rdf 1066 $ cp fieldtrip.fcdonders.nl_01/register.php 1069 $ cp fieldtrip.fcdonders.nl_01/sitemap.xml.gz how do we update the site map? It should improve presentation of results on google.

Robert Oostenveld - 2014-09-24 16:28:41 +0200

(In reply to Robert Oostenveld from comment #24) This is something Eelke wrote: 1075 $ cp fieldtrip.fcdonders.nl_01/gettweets.php the tweets (in the left bar) are not yet showing up

Robert Oostenveld - 2014-09-24 16:33:57 +0200

on it suggests that a google analytics ID is needed.

Robert Oostenveld - 2014-09-24 16:42:09 +0200

the page is not rendering properly

Robert Oostenveld - 2014-09-24 16:52:55 +0200

(In reply to Robert Oostenveld from comment #26) I copied the tracking code into the conf for the plugin. On analytics I can see that realtime is working again (now 4 users).

Robert Oostenveld - 2014-09-24 16:53:29 +0200

(In reply to Robert Oostenveld from comment #25) the tweets are again showing up!

Robert Oostenveld - 2014-09-24 17:04:23 +0200

(In reply to Robert Oostenveld from comment #24) I updated the site map with

Robert Oostenveld - 2014-09-24 17:10:03 +0200

except for some rendering problems due to FieldTripV2, it seems to me that everything is working again. Hence I declare the new wiki to be opened. Happy editing! @Core team members, please make a report here if you notice something that does now work as expected.

Robert Oostenveld - 2014-09-24 17:20:44 +0200

a quite serious problem is that the google search function is gone. Compare which is the old one, versus which is the new one.

Robert Oostenveld - 2014-09-25 12:16:24 +0200

*** Bug 2704 has been marked as a duplicate of this bug. ***

Robert Oostenveld - 2014-09-25 12:16:49 +0200

(In reply to Robert Oostenveld from comment #33) There seems to be an issue with SVG figures.

Robert Oostenveld - 2014-09-25 12:17:38 +0200

(In reply to Robert Oostenveld from comment #34) it is not only potato man, but also SVG figures missing from

Robert Oostenveld - 2014-09-25 12:48:02 +0200

(In reply to Robert Oostenveld from comment #35) the files are there. I installed the latest version of the plugin and updated conf/mime.local.conf There are now 109 figures broken: > cd /var/www/ > find . -name \*.svg | wc -l 109 I cannot fix it

Robert Oostenveld - 2014-09-25 13:53:18 +0200

given all problems with the wiki, I reverted to the old version. Which means no uploads for the moment...

Eelke Spaak - 2014-09-25 14:55:44 +0200

(In reply to Robert Oostenveld from comment #37) I have fixed the toolbar, at least somewhat, such that the mediabrowser will popup again. Inserting images from there is still problematic. However, I noted something very strange, which might be related to some of the issues we've been experiencing. If you load this: you'll see a line somewhere near the top: /* XXXXXXXXXX begin of lib/scripts/jquery/jquery.js XXXXXXXXXX */ There is no lib/scripts/jquery/ in the old wiki, only in the new... So for some reason the wiki is loading scripts from the new version. I dug around a bit to see if I could find out what this could be caused by, but could find nothing.

Eelke Spaak - 2014-09-25 15:15:55 +0200

(In reply to Eelke Spaak from comment #38) Now I deliberately broke the toolbar again, namely by re-including jQuery through our own template. We should first figure out why the js.php is outputting JavaScript from a weird folder (or why the wrong js.php is being called). If we fix that, then jQuery will not be loaded anymore, and in that case if the jQuery is not in our template, then the whole wiki will break. So it's better to now do without the toolbar for a little more, fix the js.php issue, then see how to fix the toolbar, then to risk a totally broken wiki through a bugfix.

Stephen Whitmarsh - 2014-09-25 15:20:19 +0200

Also SVGs will not display

Jim Herring - 2014-09-25 15:33:15 +0200

Eelke, is there a workaround for uploading figures to the wiki? I see that some issues have to be resolved before the toolbar is working again but if possible we need a way of uploading figures to the wiki. I noticed that the media files of the wiki are accessible through 'H:\common\matlab\fieldtrip\data\wiki\media\' Is it possible to drop files in, for example, 'H:\common\matlab\fieldtrip\data\wiki\media\tutorial\natmeg' and access these figures from the wiki by using something like: {{tutorial:natmeg:natmeg_erf5.png?700|Figure 5; blabla}} I would try it myself but I do not have rights to write to the wiki folder.

Eelke Spaak - 2014-09-25 16:04:27 +0200

(In reply to Jim Herring from comment #41) Yes, that should be possible. I see that /media/ and the files in it have a kind of weird permission setting (rwxr-xrwx). Robert, perhaps we could add write permissions for the group to /media/ and the files/folders? (I don't have the rights to do so, obviously.) @Stephen: I think the svg issue is also caused by the issue I sketched earlier (wrong script files).

Robert Oostenveld - 2014-09-25 19:55:34 +0200

(In reply to Eelke Spaak from comment #42) roboos@dccn-l024:/var/www/ 1003 $ sudo chmod -R g+w * permissions fixed.

Robert Oostenveld - 2014-10-30 13:02:16 +0100

this is actually a duplicate. Some of the work is described here, some at the former bug. *** This bug has been marked as a duplicate of bug 2223 ***

Robert Oostenveld - 2015-02-11 10:40:45 +0100

Closed several bugs that were recently resolved. Please reopen if you are not happy with the resolution.