Back to the main page.

Bug 2712 - cfg.trl option doesn't seem to work in ft_databrowser

Reported 2014-09-29 16:21:00 +0200
Modified 2021-09-16 13:53:44 +0200
Product: FieldTrip
Component: core
Version: unspecified
Hardware: PC
Operating System: Windows
Importance: P5 normal
Assigned to: Roemer van der Meij
Depends on:
Blocks: 2314
See also:

Johanna - 2014-09-29 16:21:24 +0200

The documentation of ft_databrowser mentions use of cfg.trl, only for use with trial-based data. I'm entering trial-based timelock data (output of ft_timelockanalysis with keeptrials='yes') and yet it seems to ignore my use of cfg.trl but instead reverts to timelock.sampleinfo. I looked in the code of ft_databrowser and can't find any place where cfg.trl is used. Nor is there a default set for it in the initial lines of 'set the defaults' (lines 156-182). Is this cfg option obsolete (in which case, should be removed from documentation) or should it work? Am I calling it wrongly? cfg=[]; cfg.trl=timelock.sampleinfo(2:end,:); ft_databrowser(cfg,timelock) Thank you, Johanna

Jan-Mathijs Schoffelen - 2016-07-04 17:05:39 +0200

I can confirm this. @Roemer: has this worked at some point? @Roemer: should it still work? If not, I suggest to remove it from the documentation altogether, because indeed cfg.trl does not seem to be interrogated (anymore) in the function

Roemer van der Meij - 2016-07-04 17:29:22 +0200

I never used/worked on cfg.trl, so no idea. My guess would have been that it would be used if you only give the browser a cfg (since it's cfg.trl not cfg.trials), but a quick check told me it is ignored in that case as well. No idea why. Removal seems solid to me.

Jan-Mathijs Schoffelen - 2021-09-16 13:53:44 +0200

Currently this seems to work fine.