Back to the main page.

Bug 2855 - voxel index missing in montecarlo statistics for source level data using wcm or maxsize methods

Reported 2015-02-24 10:21:00 +0100
Modified 2018-11-19 15:33:41 +0100
Product: FieldTrip
Component: inverse
Version: unspecified
Hardware: PC
Operating System: Linux
Importance: P5 normal
Assigned to: Jan-Mathijs Schoffelen
Depends on:
See also:

Yuval - 2015-02-24 10:21:18 +0100

We ran cluster based permutations using dependent sample t-test. 'maxsum' method worked but maxsize and wcm methods failed. the error was first on privet/clusterstat.m, line 292 stat(j) = -sum((abs(statrnd(negclusrnd==j,i)-negtailcritval)).^cfg.wcm_weight); we solved this by adding (negclusrnd==j) as index for negtailcritval. The function had to be modified elsewhere as well

Jan-Mathijs Schoffelen - 2015-03-04 13:33:42 +0100

Hi Yuval, Do you by any chance mean line 342, rather than 292? Could you generate some small example data structure + some code for us to reproduce it? Even better, if you could also upload the patched clusterstat.m.

Yuval - 2015-03-12 11:53:58 +0100

Created attachment 707 the faulty function please download the data from my dropbox to test the bug I ran s=ft_sourcestatistics(cfg,sub1sdOpen,sub2sdOpen,sub3sdOpen,sub5sdOpen,sub6sdOpen,sub7sdOpen,sub9sdOpen,sub10sdOpen); it got stuck on clusterstat (attached) line 342 which was called by: ft_statistics_montecarlo (line 355) ft_sourcestatistics (line 204)

Jan-Mathijs Schoffelen - 2018-11-14 16:54:18 +0100

verified and fixed. the scenario that failed was one which had a nonparametric_individual clusterthreshold, combined with cfg.clusterstatistic = 'wcm';