Back to the main page.

Bug 3233 - openGL related issues after last software upgrade of DCCN cluster

Reported 2017-01-16 15:13:00 +0100
Modified 2017-11-20 20:13:19 +0100
Product: FieldTrip
Component: plotting
Version: unspecified
Hardware: PC
Operating System: Windows
Importance: P5 normal
Assigned to: Jan-Mathijs Schoffelen
Depends on:
See also:

Jan-Mathijs Schoffelen - 2017-01-16 15:13:09 +0100

This is not strictly speaking an FT bug per se, but an issue that has popped up since the TG has upgraded the mentats (so it's a DCCN issue). In a nutshell (non-exhaustive): - matlab versions prior to 2014b (we tested 2012b and 2013b) freeze on calling ft_sourceplot (with cfg.method = 'surface'), or throw a warning ('opengl not correctly installed') and produce an empty figure - matlab2014b produces a figure with some data in it, but this is very poorly rendered. A ticket submitted to the helpdesk has bounced back to the reporter with the recommendation to take this up with somebody who is more Matlab savvy.

Jan-Mathijs Schoffelen - 2017-01-16 15:15:49 +0100

This bug report serves as a placeholder for this issue, so that we can 1) investigate further, to identify the extent of functionality that is corrupted 2) investigate further, to identify in exact detail which matlab versions are affected 3) see whether we are capable of identifying a workaround/solution, or whether we need to check with mathworks.

Jan-Mathijs Schoffelen - 2017-01-16 15:19:07 +0100

I put some data on /home/common/matlab/fieldtrip/data/test/bug3233.mat load('bug3233.mat'); figure;ft_sourceplot(cfg2,data);

Jan-Mathijs Schoffelen - 2017-01-16 15:19:58 +0100

it seems that the 'camlight' is in this case the 'boosdoener' (that is, for version 2014b)

Jan-Mathijs Schoffelen - 2017-01-18 14:18:25 +0100

I just had a chat with Edward, and he mentioned that TG has done some tests, noticing that probably higher Matlab versions should work 'well' again. I quickly tried on matlab2016b, and that indeed looks much better.

DCCN Helpdesk - 2017-02-09 15:09:56 +0100

We googled some more about these opengl issues. According to this link: ...also referring to this link: ...people suggest to re-create a new symlink to the libstdc++ system library in stead of the matlab library. This is what I tried for matlab2012b (and only this version...) As root: # cd /opt/matlab/R2012b/sys/os/glnxa64 # ls -> # mv # ln -s /usr/lib64/ Now opengl functionality seems to be available again though as TG-member I am afraid to break other matlab functionalities.... That's why for now we only tested with matlabversion 2012b. Can anyone confirm opengl functionality and check if matlab2012b still runs as expected? Best, Ed.

Jan-Mathijs Schoffelen - 2017-02-09 15:28:59 +0100

Using the test data as specified in my comment 2, the visualization works fine! I did not exhaustively test any other functionality, but basic arithmetic operations still work (I tried 1+1 on the command line, and got 2 as an answer :o) )

Jan-Mathijs Schoffelen - 2017-03-14 12:52:28 +0100

There's not so much to be done about this. Recommendation: -run functionality that heavily relies on advanced openGL graphics stuff locally. -us a late version of matlab