Back to the main page.

Bug 3421 - ft_prepare_headmodel failing on more than 5 conductivities

Reported 2018-04-09 03:42:00 +0200
Modified 2019-08-10 12:37:32 +0200
Product: FieldTrip
Component: forward
Version: unspecified
Hardware: Macintosh
Operating System: Mac OS
Importance: P5 normal
Assigned to:
Depends on:
See also:

- 2018-04-09 03:42:52 +0200

Hi sirs, I get an error mentioning that 'a conductivity value should be specified for each compartment' when I run ft_prepare_headmodel with a segmented mri. This mri file has 5 segments and a value for each, but it fails. The file I'm using as segmentedmri is accessible here. I'm running the command hdm = ft_prepare_headmodel(cfg, segmentedmri); and cfg only has the field conductivity ([0.33 0.14 1.79 0.01 0.43]). Thank you for your attention. Gonçalo

Jan-Mathijs Schoffelen - 2018-04-10 15:45:53 +0200

This bug report is incomplete and poor in quality. Besides the data that can be downloaded contains an MRI image with 'brain', 'skull' 'scalp' and 'anatomy', so it's not clear why you think this should work with an arbitrary number of conductivities specified. I change the status to wontfix, until you are able to - motivate what you try to achieve - document what you have done, and what the specific error is that you get - describe what you have tried to solve it yourself - upload some data and code that allows us to reproduce your problem

Robert Oostenveld - 2019-08-10 12:37:32 +0200

This closes a whole series of bugs that have been resolved (either FIXED/WONTFIX/INVALID) for quite some time. If you disagree, please file a new issue on