Back to the main page.

Bug 512 - ft_sourceplot can't plot mri

Reported 2011-03-02 11:14:00 +0100
Modified 2011-03-03 10:04:41 +0100
Product: FieldTrip
Component: plotting
Version: unspecified
Hardware: PC
Operating System: Linux
Importance: P1 normal
Assigned to: Jan-Mathijs Schoffelen
Depends on:
See also:

Lilla Magyari - 2011-03-02 11:14:39 +0100

hi, ft_sourceplot worked last night, but today morning I could not use it anymore. I have tried to do this: cd /home/coherence/roboos/data/lilmag/subjects/subject01/mri; mri = ft_read_mri('filled.mgz'); cfg = []; cfg.interactive = 'yes'; figure;ft_sourceplot(cfg, mri); And I have got this: >> ft_sourceplot(cfg, mri); the input is volume data with dimensions [256 256 256] ??? Undefined function or variable "data". Error in ==> ft_datatype_vol at 72 if isfield(data, 'xgrid'), data = rmfield(data, 'xgrid'); end Error in ==> ft_checkdata at 169 data = ft_datatype_vol(data); Error in ==> ft_sourceplot at 260 data = ft_checkdata(data, 'datatype', 'volume', 'feedback', 'yes'); thanks for helping out with it. Lilla

Jan-Mathijs Schoffelen - 2011-03-02 11:31:47 +0100

This was caused by a typo in ft_datatype_source, it has been fixed and I suspect that it works again. JM