Back to the main page.

Bug 583 - ft_selectdata probably has difficulties if nrpt/nsubj is equal to any of the other dimlengths.

Reported 2011-04-18 08:53:00 +0200
Modified 2011-04-20 14:01:28 +0200
Product: FieldTrip
Component: core
Version: unspecified
Hardware: PC
Operating System: Mac OS
Importance: P1 normal
Assigned to: Jan-Mathijs Schoffelen
Depends on:
See also:

Jan-Mathijs Schoffelen - 2011-04-18 08:53:29 +0200

Dear Jan-Mathijs, I re-runned the script with a recent version of Fieldtrip (20110412). The struct Data now looks like this: label: {31x1 cell} time: [1x350 double] individual: [31x31x350 double] dimord: 'subj_chan_time' cfg: [1x1 struct] However, I still get the same error: ??? Attempted to access n(1); index out of bounds because numel(n)=0. Error in ==> dimlength at 115 if ~all(n==n(1)) Error in ==> dimlength at 46 n{k}(i) = dimlength(data, dimtok{i}, fn{k}); Error in ==> seloverdim at 39 [reduceddim, fntmp] = dimlength(data); Error in ==> ft_selectdata at 563 if selectchan, data = seloverdim(data, 'chan', selchan, fb); end There seems to be a problem in function dimlength. Best, Mark I think that this is caused by the data having both 31 channels and subjects. try to reproduce this.

Jan-Mathijs Schoffelen - 2011-04-19 11:27:38 +0200

*** This bug has been marked as a duplicate of bug 590 ***

Jan-Mathijs Schoffelen - 2011-04-19 11:27:56 +0200

*** This bug has been marked as a duplicate of bug 586 ***