Back to the main page.

Bug 585 - invalid MEX file error in clusterstat

Reported 2011-04-19 00:57:00 +0200
Modified 2011-11-11 11:19:44 +0100
Product: FieldTrip
Component: external
Version: unspecified
Hardware: PC
Operating System: Windows
Importance: P1 normal
Assigned to: Robert Oostenveld
Depends on:
See also:

Ingrid Nieuwenhuis - 2011-04-19 00:57:49 +0200

Hi I'm running ft_sourcestatistics on the mentat cluster with the following cfg: %%% cluster statistics cfg = []; cfg.parameter = 'stat'; cfg.method = 'montecarlo'; cfg.statistic = 'depsamplesT'; cfg.clusteralpha = 0.05; cfg.numrandomization = 1000; cfg.correctm = 'cluster';,1:2*Nsub) = [ones(1,Nsub) 2*ones(1,Nsub)];,1:2*Nsub) = [1:Nsub 1:Nsub]; cfg.ivar = 1; cfg.uvar = 2; cfg.alpha = 0.025; %one sided alpha!! stat_clus = ft_sourcestatistics(cfg, Rem{1:Nsub}, Rec{1:Nsub}); and get the below error, am I doing anything wrong (I must admit, I'm running a 2 year old script (which has already generated new data out of 2 year old source data without any errors: very impressive backward compatibility!), or is there just a MEX file missing? Thanks, Ingrid ??? Invalid MEX-file '/home/common/matlab/fieldtrip/external/spm8/spm_bwlabel.mexa64': /home/common/matlab/fieldtrip/external/spm8/spm_bwlabel.mexa64: undefined symbol: mxCreateNumericArray_700. Error in ==> fieldtrip/private/clusterstat at 189 [posclusobs, posnum] = spm_bwlabel(tmp, 6); % use spm_bwlabel for source data to avoid usage of image toolbox Error in ==> statistics_montecarlo at 322 [stat, cfg] = clusterstat(cfg, statrand, statobs,'issource',issource); Error in ==> fieldtrip/private/statistics_wrapper at 285 [stat, cfg] = statmethod(cfg, dat,, 'issource',issource); Error in ==> ft_sourcestatistics at 114 [stat, cfg] = statistics_wrapper(cfg, varargin{:}); ----------------------------------------------- I got this reply from Guillaume over the FieldTrip list, but since this is error on mentat cluster, I'm posting it here in bugzilla. Hi Ingrid, spm_bwlabel.mexa64 doesn't seem to be compatible with your platform: which version of MATLAB are you using, under which system (uname -a)? I assume that the MEX files provided with FieldTrip are the ones shipped with SPM, but you might want to try using the one that you can find in the SPM distribution: If you get the same error message, you will have to recompile the MEX files. Follow the instructions from here: and copy the MEX files you will have created over the ones that are in fieldtrip/external/spm8/ Best regards, Guillaume.

Ingrid Nieuwenhuis - 2011-04-21 23:41:41 +0200

ingnie: It works now, did you fix it? Don't get the error again. Switched from using matlab71 to matlab75

Ingrid Nieuwenhuis - 2011-04-21 23:56:46 +0200

(In reply to comment #1) > ingnie: It works now, did you fix it? Don't get the error again. Switched from > using matlab71 to matlab75 I checked, it works fine in matlab75, but not in matlab71

Robert Oostenveld - 2011-04-27 20:55:26 +0200

changed multiple bugs that already had names attached from NEW into ASSIGNED. If you (as the assignee) don't agree, please reassign it to fieldtrip-bugs and change the status back into NEW.

Robert Oostenveld - 2011-10-12 12:32:59 +0200

(cleaning up old bugs...) we don't have to support mex files all the way back to matlab 7.1

Robert Oostenveld - 2011-11-11 11:19:44 +0100

I closed all bugs that were recently resolved.